Men Of war Collection Archive structure corrupted

Troubleshoot For Games
Post Reply
Posts: 1
Joined: 05 Oct 2021, 09:59

Hello, recently I downloaded men of war collection repack2 posted by King, I tried installing it with my Disk that has 40 gb free. Suddenly this error popped "ISDone.dll An error occured while decompressing: Archive header is corrupt! Unarc.dll returned an error code: -14 ERROR: archive structure corrupted (decompression of control block failed) I have 2 gb ram and I set my virtual memory as 3000 for start and 6000 for maximum, any help please? Should I change my virtual memory? I tried with safe mode too, installed the dlls and put them in system32 but none will work.
User avatar
Posts: 1949
Joined: 23 Jun 2012, 15:41

2gb is not enough for the installer, if i remember rightly it needs 2gb just to decompress so that doesnt include what windows is already using.
i do not have much experience with low ammounts of ram so hopfully somebody else can help.
Easy Links For Navigating Around The Site
KaOs Game Releases | Game Issues | Broken Links
(Always use the forum instead of PMing us)
“To alcohol! The cause of... and solution to... all of life's problems”
― Matt Groening
Post Reply