Company.Of.Heroes.Complete.Edition.REPACK-KaOs install error

Troubleshoot For Games
Post Reply
Posts: 2
Joined: 25 Jul 2018, 11:02

Company.Of.Heroes.Complete.Edition.REPACK-KaOs install error

Post by zeromido » 25 Jul 2018, 11:27

Hi everyone!
I downloaded Company.Of.Heroes.Complete.Edition.REPACK-KaOs, extracted it, and ran the installer but I got this error after around 5 minutes:


I tried:
-Running the installer again.
-Running the installer in Safe Mode (Minimal and Network).
-Increasing Virtual RAM by 1 GB.
-Disabling antivirus (it doesn't start in Safe Mode anyway).
-Deleting temporary files.
-Moving files to another short path.
-Choosing a shorter path than the default one.
-Unchecking all available checkboxes.


System Specifications:
Windows 7 Ultimate 32-bit SP1
Pentium(R) Dual-Core CPU E5700 @ 3.00GHz
Intel(R) G41 Express Chipset
2.00GB RAM
2012 MB (System managed) Virtual Memory
Disk partition (C:)
Total: 100 GB
Free: 35 GB
Required: 11.38 GB
Final Size: 7.65 GB

Thanks in advance :)
Last edited by zeromido on 25 Jul 2018, 14:49, edited 1 time in total.

User avatar
Posts: 417
Joined: 30 Jul 2014, 04:06
Location: 4th Reich HQ, Antarctica

Re: Company.Of.Heroes.Complete.Edition.REPACK-KaOs install error

Post by TheMaster » 26 Jul 2018, 04:47

KiNG or someone else might come in & help but in the meantime have you tried going through the other threads in this section to see if there are already solutions to this issue? I know it's a fairly common one with regard to any downloaded archive files.

Also I just did a quick search & I could only find "Company.Of.Heroes.Complete.Edition-KaOs" (without the "REPACK" part in it as it's from 2014 before that naming was used). Is that the release you have? If you have downloaded one with a slightly different name from a different source that could be a possible problem.

Here's a few more ideas -

1. Are you sure the archives are not corrupted? Try downloading again from different links although no guarantee the files are not corrupted at the provider end due to age, etc.
2. If you got it via torrent try rehashing to see if there was a problem. If there was it should redownload the affected parts.
3. You only have 2GB RAM. While that may be enough to barely run the game it may not be enough to properly unpack/install it. 2GB is really way below minimum by today's standards!
4. Try running it on a different computer with different OS (or Win 7 64bit seeing as yours is 32bit) & more RAM/drive space, etc to see if you get the same issue.
5. Empty recycle bin & clean out all temp folders including %TEMP
6. Make sure to run the process as Admin especially if running it or installing to C:/ drive.
7. You could try upping your Virtual RAM - set the upper & lower limits at 4GB (4096MB) rather than system managed.
8. FitGirl has a Troubleshooting Guide HERE that covers most of all this more.

If I had to take a complete stab in the dark I'd say the biggest problem is your tiny amount of RAM but also the downloaded rars might be corrupt. Also being on 32bit may be an issue with the unpacking process (even though the game itself might run on 32bit).
"Anger is an energy!"
- John Lydon
Game Issues Forum is kindly provided HERE
Game Issues & Broken Link requests posted in the wrong place will be deleted!

User avatar
Posts: 1548
Joined: 23 Jun 2012, 15:41

Re: Company.Of.Heroes.Complete.Edition.REPACK-KaOs install error

Post by KiNG » 26 Jul 2018, 08:24

yeah the ram is the issue, it needs 2gb just for decompression but your os is using most of that already.
setting the virtual ram alot higher should fix it but you be in for one hell of a long install time.
Easy Links For Navigating Around The Site
KaOs Game Releases | Game Issues | Broken Links
(Always use the forum instead of PMing us)
“To alcohol! The cause of... and solution to... all of life's problems”
― Matt Groening

Posts: 2
Joined: 25 Jul 2018, 11:02

Re: Company.Of.Heroes.Complete.Edition.REPACK-KaOs install error

Post by zeromido » 27 Jul 2018, 18:05

Sorry for the late reply. After doing some research I found out that the RAM is the issue because the ARC archive's decompression memory is 4 GB, which is bigger than 3/4 my RAM.
Quoted from FreeArc GUI Docs:
"Pay a special attention to the Decompression memory field, which shows how much RAM will be used for decompression process. If it’s greater that ¾ of your total RAM size – this archive can’t be decompressed on your computer."
To verify that, I tried to install the repack on another system with 6 GB RAM, the game was extracted successfully, and ran fine.

TL;DR, If you have this problem, and tried all the solutions listed in FitGirl's Troubleshooting Guide, try the repack on another system with at least 4 GB RAM.

Post Reply